Posted Date: December 14, 2017

Author:  Federal Student Aid

Subject: Reminder: Mandatory EDconnect Patch

In a November 3, 2017 Electronic Announcement posted to the Information for Financial Aid Professionals (IFAP) website, we informed EDconnect users of a mandatory patch for the software. Users must install the EDconnect 8.x patch, available for download on the Federal Student Aid Download (FSAdownload) website, in order to maintain access to the application.

Important Note: To avoid losing access to EDconnect, all users must download and install the EDconnect 8.x patch by Saturday, December 16, 2017.

As stated previously, the update to EDconnect only impacts a user’s authentication (login); the changes will be transparent to the user. No functionality changes will be made with the update that will impact users. The EDconnect 8.x patch will work with any version of EDconnect that a user is currently running.

Note: EDconnect must already be installed prior to installation of the patch. To download the latest version of EDconnect and the EDconnect Installation and User Guide, as well as the patch, go to the "Software and Associated Documents" section of the FSAdownload website.

We appreciate the immediate attention of EDconnect users to this important update.

Contact Information

If you have questions about this information, contact CPS/SAIG Technical Support at 1-800-330-5947 (TDD/TTY 1-800-511-5806) or by email at CPSSAIG@ed.gov.

   

End of Page